Bundle is in installed state while doing AEM 6.5 upgrade from 6.3 | Community
Skip to main content
Level 3
Oct 16, 2019 8:25 AM UTC
Solved

Bundle is in installed state while doing AEM 6.5 upgrade from 6.3

we are trying to upgrade from 6.3 to 6.5. changed uber jar version to 6.5.2 and deployed the jar file in new AEM 6.5 version but bundle is installed state with the below error.

org.apache.felix.http.jetty %bundles.pluginTitle: Cannot start (org.osgi.framework.BundleException: Unable to resolve wnt-core [613](R 613.0): missing requirement [wnt-core [613](R 613.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.distribution)(version>=0.3.0)(!(version>=1.0.0))) Unresolved requirements: [[wnt-core [613](R 613.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.distribution)(version>=0.3.0)(!(version>=1.0.0)))])

org.osgi.framework.BundleException: Unable to resolve wnt-core [613](R 613.0): missing requirement [wnt-core [613](R 613.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.distribution)(version>=0.3.0)(!(version>=1.0.0))) Unresolved requirements: [[wnt-core [613](R 613.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.sling.distribution)(version>=0.3.0)(!(version>=1.0.0)))]

I have understood that org.apache.sling.distribution dependecy version should be greater than 0.3.0 and less than 1.0.0 . So I have tried adding below dependency but the issue still persists. Please do let me know if I am missing something here. Any leads will be appreciated.

<dependency>

<artifactId>org.apache.sling.distribution.api</artifactId>

<version>0.3.0</version>

<groupId>org.apache.sling</groupId>

<scope>provided</scope>

</dependency>

This post is no longer active and is closed to new replies. Need help? Start a new post to ask your question.
aemmarc2Accepted solution
Employee
Oct 16, 2019 2:33 PM UTC

There were a ton of deprecations in the 6.5 uber jar.  I suggest trying out this build : https://repo.adobe.com/nexus/content/repositories/releases/com/adobe/aem/uber-jar/6.5.0.0/uber-jar-6.5.0.0-apis-with-dep…

5 replies

Employee
Oct 17, 2019 12:03 PM UTC

Can you log a daycare ticket and we can further investigate whats causing the issue?

Translate
Level 3
Oct 17, 2019 9:46 AM UTC

I have tried with uber jar deprecated apis but it didn't work. unfortunately issue still persists.

Translate
aemmarc2Accepted solution
Employee
Oct 16, 2019 2:33 PM UTC

There were a ton of deprecations in the 6.5 uber jar.  I suggest trying out this build : https://repo.adobe.com/nexus/content/repositories/releases/com/adobe/aem/uber-jar/6.5.0.0/uber-jar-6.5.0.0-apis-with-dep…

Translate
Level 3
Oct 16, 2019 12:19 PM UTC

yes I have 6.5.2 service pack installed.

Translate
Employee
Oct 16, 2019 12:15 PM UTC

Can you confirm the AEM version is 6.5.2 ? Ideally, you should be using the same version of uber jar as the AEM version.

Translate