Dependency issue : com.adobe.cq.social.scf.core,version=[1.1,2) -- Cannot be resolved | Community
Skip to main content
Rajeev_Kumar
Level 3
Jun 15, 2017 5:56 PM UTC
Solved

Dependency issue : com.adobe.cq.social.scf.core,version=[1.1,2) -- Cannot be resolved

Hi Experts,

I've an fully updated AEM 6.2 instance. I am trying to extend some AEM communities component functionality. For that I used the dependency

<dependency>

  <groupId>com.adobe.cq.social</groupId>

  <artifactId>cq-socialcommunities-api</artifactId>

  <version>1.11.170</version>

  <scope>provided</scope>

</dependency>

<dependency>

  <groupId>com.adobe.aem</groupId>

  <artifactId>uber-jar</artifactId>

  <version>6.2.0</version>

  <scope>provided</scope>

  <classifier>apis</classifier>

</dependency>.

Now, I am getting the issue in felix console as 'com.adobe.cq.social.scf.core,version=[1.1,2) -- Cannot be resolved' .
When I checked the version of above package, it is

<dependency>

  <groupId>com.adobe.cq.social</groupId>

  <artifactId>cq-social-scf-api</artifactId>

  <version>2.0.14</version>

  <scope>provided</scope>

</dependency>

When I checked in on maven repository, latest version of 'cq-socialcommunities-api' is same as I am using and latest version of 'cq-social-scf-api exposed is 1.0.8.

Please correct me if I am wrong.

Also, suggest me to resolve the issue.

Thanks

Rajeev

This post is no longer active and is closed to new replies. Need help? Start a new post to ask your question.
JK_Kendall
JK_KendallAccepted solution
Level 9
Jun 15, 2017 7:57 PM UTC

You're referencing AEM 6.3 Communities jar

You need to follow these instructions (do not include individual Communities APIs!) and adjust to match the feature pack you have installed for AEM 6.2 Communities

Using Maven for Communities

Communities Version History​

- JK

11 replies

Rajeev_Kumar
Level 3
Jun 19, 2017 7:07 AM UTC

Hi Tuhin,

I am exploring the communities for learning purpose. Not working for any client .

Translate
Tuhin_Ghosh
Level 8
Jun 19, 2017 7:04 AM UTC

The client you have been working for should have a day care account and from that account you could log a daycare ticket.

Thanks

Tuhin

Translate
Rajeev_Kumar
Level 3
Jun 19, 2017 6:57 AM UTC

kautuksahni​ scottm​

Would you please look into it.
I don't have the right to create a day care ticket.

Translate
Rajeev_Kumar
Level 3
Jun 19, 2017 6:16 AM UTC

If I am using the Aem 6.2 version without any FP, it is working fine. My bundle is active with dependency

<dependency>

  <groupId>com.adobe.cq.social</groupId>

  <artifactId>cq-socialcommunities-api</artifactId>

  <version>1.10.111</version>

  <scope>provided</scope>

</dependency>

because Aem is exposing 1.1.32 version of 'com.adobe.cq.social.scf.core' api.

Translate
Tuhin_Ghosh
Level 8
Jun 19, 2017 6:14 AM UTC

I understand the issue. Bit weird, I would suggest you create a day care ticket for the same and let the support team come back to you.

Thanks

Tuhin

Translate
Rajeev_Kumar
Level 3
Jun 19, 2017 5:14 AM UTC

I tried with version '1.10.167' also. But as my AEM is exposing 2.0.14 of 'com.adobe.cq.social.scf.core' and 'cq-socialcommunities-api' version '1.10.167' is using the version '[1.1,2)', it is not being resolved.
I also tried uploading the version '1.1.32' of 'com.adobe.cq.social.scf.core'. But installing this version causes other bundles of communities to go in installed state.

Installing version '1.0.8' is also not working.

Translate
Tuhin_Ghosh
Level 8
Jun 16, 2017 3:33 AM UTC

Try replacing your pom with the below dependency and see if it works.

<dependency>

    <groupId>com.adobe.cq.social</groupId>

    <artifactId>cq-social-scf-api</artifactId>

    <version>1.0.8</version>

    <scope>provided</scope>

</dependency>

Translate
Rajeev_Kumar
Level 3
Jun 16, 2017 3:30 AM UTC

That my question is. If Aem is exposing the version 2.0.14 in jar, I am being kind of forced to use the version 2 or greater and this version is not in public repo.

The alternative could be to install the smaller version manually in OSGi.

Translate
Tuhin_Ghosh
Level 8
Jun 15, 2017 11:11 PM UTC

Version [1.1,2) means 1.0 <= x < 2.0 , so you have to use a version less than 2.0 and greater than equals to 1.0. version 2.0.14 won't just work.

Translate
JK_Kendall
Level 9
Jun 15, 2017 8:01 PM UTC

In other words, if you have AEM 6.2 GA, the version is 1.9.236

Else, if you have a feature pack installed - the latest is recommended - then the version is 1.10.xxx

<dependency>

    <groupId>com.adobe.cq.social</groupId>

    <artifactId>cq-socialcommunities-api</artifactId>

    <version>1.10.167</version>

    <scope>provided</scope>

</dependency>

<dependency>

    <groupId>com.adobe.aem</groupId>

    <artifactId>uber-jar</artifactId>

    <version>6.2.0</version>

    <scope>provided</scope>

    <classifier>apis</classifier>

</dependency>

- JK

Translate