Error while deploying custom AEM component | Community
Skip to main content
khushbooa339108
Level 2
Dec 18, 2018 10:03 AM UTC
Solved

Error while deploying custom AEM component

Hi,

I have built a custom AEM component 'Byline' by following AEM WKND tutorial. However, after deployment, I am not able to find my component model in AEM web console for Sling models. I am using AEM 6.4 quickstart, getting following errors while using this component:

Caused by: org.apache.sling.scripting.sightly.SightlyException: Compilation errors in org/apache/sling/scripting/sightly/apps/wknd/components/content/byline/byline_html.java:

Line 28, column 1272 : Only a type can be imported. com.adobe.aem.guides.wknd.core.components.Byline resolves to a package

Line 49, column 2354 : Byline cannot be resolved to a type

    at org.apache.sling.scripting.sightly.impl.engine.SightlyJavaCompilerService.compileSource(SightlyJavaCompilerService.java:173) [org.apache.sling.scripting.sightly:1.0.48.1_3_1]

    ... 286 common frames omitted

Unable to resolve com.adobe.aem.guides.wknd.core [551](R 551.19): missing requirement [com.adobe.aem.guides.wknd.core [551](R 551.19)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.wcm.core.components.models)(version>=12.5.0)(!(version>=13.0.0))) Unresolved requirements: [[com.adobe.aem.guides.wknd.core [551](R 551.19)] osgi.wiring.package; (&(osgi.wiring.package=com.adobe.cq.wcm.core.components.models)(version>=12.5.0)(!(version>=13.0.0)))]

    at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4149)

    at org.apache.felix.framework.Felix.startBundle(Felix.java:2119)

    at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:998)

    at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:984)

    at org.apache.sling.installer.core.impl.tasks.BundleStartTask.execute(BundleStartTask.java:97) [org.apache.sling.installer.core:3.8.12]

    at org.apache.sling.installer.core.impl.OsgiInstallerImpl.doExecuteTasks(OsgiInstallerImpl.java:902) [org.apache.sling.installer.core:3.8.12]

    at org.apache.sling.installer.core.impl.OsgiInstallerImpl.executeTasks(OsgiInstallerImpl.java:737) [org.apache.sling.installer.core:3.8.12]

    at org.apache.sling.installer.core.impl.OsgiInstallerImpl.run(OsgiInstallerImpl.java:287) [org.apache.sling.installer.core:3.8.12]

    at java.lang.Thread.run(Thread.java:748)

Also, I can see following error while viewing my site OSGi bundle in AEM Web console:

com.adobe.cq.wcm.core.components.models,version=[12.5,13) -- Cannot be resolved

I am not sure if I am missing any configuration or mvn dependency. Can I please get some help to resolve these errors?

This post is no longer active and is closed to new replies. Need help? Start a new post to ask your question.
khushbooa339108
khushbooa339108Accepted solution
Level 2
Dec 19, 2018 9:31 AM UTC

Thanks for replying. It seems the tutorial was recently updated to use Core components 2.2.0 and I was using Core components 2.0.4 for models as required earlier. I have updated the configurations accordingly which has resolved all errors.

12 replies

chrisatsirius
Level 2
Sep 6, 2019 3:09 PM UTC

I found this and I applied to my wknd and it worked for me:

https://youtu.be/lKWHsVh1hRA

Translate
matth39107775
Level 2
Sep 3, 2019 9:31 PM UTC

Since my issue was slightly different I just ended up making a separate post

Byline cannot be resolved to a type using WKND tutorial

Translate
chrisatsirius
Level 2
Sep 3, 2019 9:27 PM UTC

I m still trying to figure out what and where the issue is.

Translate
matth39107775
Level 2
Sep 3, 2019 8:57 PM UTC

Yeah I have

<core.wcm.components.version>2.5.0</core.wcm.components.version>

and

   <dependency>

   <groupId>com.adobe.cq</groupId>

   <artifactId>core.wcm.components.core</artifactId>

   <version>2.5.0</version>

   <scope>provided</scope>

   </dependency>

in my pom.xml but still have the same error

Translate
chrisatsirius
Level 2
Sep 3, 2019 8:55 PM UTC

Yes, I was talking about pom.xml file I updated.

Translate
matth39107775
Level 2
Sep 3, 2019 8:52 PM UTC

What did you update in your configurations? Are you referring to the pom.xml files?

Translate
chrisatsirius
Level 2
Aug 30, 2019 3:23 PM UTC

I am using VSCode, I experienced the same error, the parent POM already updated to core 2.4.0.

When I built with mvn, there is no error.

I wonder what else can I look at? How would I know which version of core should be used?

Thanks in advanced.

Translate
smacdonald2008
Level 10
Dec 19, 2018 4:05 PM UTC

thanks for posting your fix!

Translate
khushbooa339108
khushbooa339108AuthorAccepted solution
Level 2
Dec 19, 2018 9:31 AM UTC

Thanks for replying. It seems the tutorial was recently updated to use Core components 2.2.0 and I was using Core components 2.0.4 for models as required earlier. I have updated the configurations accordingly which has resolved all errors.

Translate
edubey
Level 10
Dec 18, 2018 5:37 PM UTC

1. Can you attach the package for community?

2. Did you try Troubleshooting steps here

https://helpx.adobe.com/experience-manager/kt/sites/using/getting-started-wknd-tutorial-develop/part6.html#Troubleshooting

Translate