upgrade to aem 6.5.17 errors | Community
Skip to main content
sreenu539
Level 7
Sep 14, 2023 8:57 PM UTC
Solved

upgrade to aem 6.5.17 errors

i am seeing below issues after aem instance upgrade to 6.5.17

 

 

 

 

14.09.2023 13:50:00.341 *ERROR* [FelixStartLevel] ERROR: Bundle '632' Error starting jcrinstall:/libs/fd/channelcore/install/channel-core-impl-2.0.84.jar (org.osgi.framework.BundleException: Unable to resolve com.adobe.aemfd.channelcore-channel-core-impl [632](R 632.0): missing requirement [com.adobe.aemfd.channelcore-channel-core-impl [632](R 632.0)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.msm.api)(version>=5.9.0)(!(version>=5.11.0))) Unresolved requirements: [[com.adobe.aemfd.channelcore-channel-core-impl [632](R 632.0)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.msm.api)(version>=5.9.0)(!(version>=5.11.0)))]) org.osgi.framework.BundleException: Unable to resolve com.adobe.aemfd.channelcore-channel-core-impl [632](R 632.0): missing requirement [com.adobe.aemfd.channelcore-channel-core-impl [632](R 632.0)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.msm.api)(version>=5.9.0)(!(version>=5.11.0))) Unresolved requirements: [[com.adobe.aemfd.channelcore-channel-core-impl [632](R 632.0)] osgi.wiring.package; (&(osgi.wiring.package=com.day.cq.wcm.msm.api)(version>=5.9.0)(!(version>=5.11.0)))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4368) at org.apache.felix.framework.Felix.startBundle(Felix.java:2281) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) at java.base/java.lang.Thread.run(Thread.java:829) 14.09.2023 13:50:08.773 *ERROR* [FelixStartLevel] ERROR: Bundle '690' Error starting jcrinstall:/libs/fd/signatures/install/adobe-aemfd-signatures-6.0.30.jar (java.lang.NoClassDefFoundError: org/bouncycastle/jce/provider/BouncyCastleProvider) java.lang.NoClassDefFoundError: org/bouncycastle/jce/provider/BouncyCastleProvider at com.adobe.fd.signatures.activator.Activator.start(Activator.java:34) at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:698) at org.apache.felix.framework.Felix.activateBundle(Felix.java:2402) at org.apache.felix.framework.Felix.startBundle(Felix.java:2308) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1539) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308) at java.base/java.lang.Thread.run(Thread.java:829) Caused by: java.lang.ClassNotFoundException: org.bouncycastle.jce.provider.BouncyCastleProvider not found by adobe-aemfd-signatures [690] at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1597) at org.apache.felix.framework.BundleWiringImpl.access$300(BundleWiringImpl.java:79) at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1982) at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522) ... 7 more

 

 

 


 

 

seeing a flash of "html resource rendered" dump while loading pages on author.

 

Has anyone encountered these issues? 

 

Thanks,

Sri

 

 

 

This post is no longer active and is closed to new replies. Need help? Start a new post to ask your question.
A_H_M_Imrul
A_H_M_ImrulAccepted solution
New Participant
Sep 15, 2023 6:26 AM UTC

Hello @sreenu539,

 

I managed to upgrade the AEM version to 6.5.17 without any issue.

Please make sure you follow the steps recommended by Adobe: https://experienceleague.adobe.com/docs/experience-manager-65/release-notes/service-pack/6.5.17.html?lang=en#install

 

Thanks 

4 replies

kautuk_sahni
Employee
Sep 18, 2023 7:11 AM UTC

@sreenu539 Did you find the suggestions from users helpful? Please let us know if more information is required. Otherwise, please mark the answer as correct for posterity. If you have found out solution yourself, please share it with the community.

Translate
Kautuk Sahni
DPrakashRaj
New Participant
Sep 17, 2023 7:50 PM UTC

Did you upgraded the aem-Uber jar as well to the 6.5.18 with service pack upgrade?

it seems your project jar is looking for the older version of the com.day.cq.wcm.msm.api jar 

Translate
TarunKumar
New Participant
Sep 15, 2023 11:00 AM UTC

Hi @sreenu539 ,

There are some dependency in pom which are not compatible with uber 6.5.17. Please make sure there are no conflict among them. Make sure to updtae the dependency one by one.

Thanks
Tarun

Translate
A_H_M_Imrul
A_H_M_ImrulAccepted solution
New Participant
Sep 15, 2023 6:26 AM UTC

Hello @sreenu539,

 

I managed to upgrade the AEM version to 6.5.17 without any issue.

Please make sure you follow the steps recommended by Adobe: https://experienceleague.adobe.com/docs/experience-manager-65/release-notes/service-pack/6.5.17.html?lang=en#install

 

Thanks 

Translate