WCMUsePojo in AEM6.3 not working | Community
Skip to main content
Employee
Jun 9, 2017 7:52 AM UTC
Solved

WCMUsePojo in AEM6.3 not working

Hi,

I have started developing on AEM 6.3 but there are some dependency issues. The package com.adobe.cq.sightly is not resolved in aem 6.3 felix console. It gives error like this

com.adobe.cq.sightly com.adobe.cq.sightly,version=[3.1,4) -- Cannot be resolved

I am using a class which extends WCMUsePojo. I have also included uber.jar in the pom.

Can you point me to if there is some change here in 6.3 for this. Is it that it now allows only sling models to use ?

Regards,

This post is no longer active and is closed to new replies. Need help? Start a new post to ask your question.
smacdonald2008
smacdonald2008Accepted solution
Level 10
Jun 9, 2017 4:28 PM UTC

Just tested this - only difference from this artilce

Adobe Experience Manager Help | Creating an Adobe Experience Manager HTML Template Language component that uses the WCMU…

is use this:

dependency>

               <groupId>com.adobe.aem</groupId>

               <artifactId>uber-jar</artifactId>

               <version>6.3.0</version>

               <!-- for AEM6.1 use this version     : <version>6.1.0</version> -->

               <!-- for AEM6.1 SP1 use this version : <version>6.1.0-SP1-B0001</version> -->

               <!-- for AEM6.1 SP2 use this version : <version>6.1.0-SP2</version> -->

               <!-- for AEM6.2 use this version     : <version>6.2.0</version> -->

               <classifier>obfuscated-apis</classifier>

               <scope>provided</scope>

           </dependency>

          

           <dependency>

               <groupId>org.apache.geronimo.specs</groupId>

               <artifactId>geronimo-atinject_1.0_spec</artifactId>

               <version>1.0</version>

               <scope>provided</scope>

           </dependency>

New article here: https://helpx.adobe.com/experience-manager/using/aem63_htl.html

13 replies

smacdonald2008
Level 10
Jun 23, 2017 2:01 PM UTC

Did you follow the article I posted exactly as is. It works!

Translate
Level 2
Jun 23, 2017 1:59 PM UTC

I included uber jar dependency and still see the same error. Any other solution I can try ?

com.day.cq.mailer,version=[5.6,6) -- Cannot be resolved

com.day.jcr.vault.util,version=[2.4,3) -- Cannot be resolved

Translate
Feike_Visser1
Employee
Jun 22, 2017 1:24 PM UTC

Hard to say without details, I would always first check the logfile (error.log)

Translate
Level 2
Jun 22, 2017 1:22 PM UTC

Thanks for your reply. One more question - we just did jcr to OAK migration and moved all 5.6 version sites to 6.3. When I open the pages that were working in 5.6 in 6.3 it shows just blank page. Is it because my bundles are not resolving ? Is this expected behavior when we migrate until we make code compatible to 6.3 ?

Translate
Feike_Visser1
Employee
Jun 22, 2017 1:16 PM UTC

Yes, also use

  <classifier>apis</classifier>

Translate
Level 2
Jun 22, 2017 1:13 PM UTC

Thanks. No , I haven't added  uber dependency in POM. Do I need to add below dependency and remove the deprecated one?

<groupId>com.adobe.aem</groupId>

               <artifactId>uber-jar</artifactId>

               <version>6.3.0</version>

               <!-- for AEM6.1 use this version     : <version>6.1.0</version> -->

               <!-- for AEM6.1 SP1 use this version : <version>6.1.0-SP1-B0001</version> -->

               <!-- for AEM6.1 SP2 use this version : <version>6.1.0-SP2</version> -->

               <!-- for AEM6.2 use this version     : <version>6.2.0</version> -->

               <classifier>obfuscated-apis</classifier>

               <scope>provided</scope>

           </dependency>

Translate
Feike_Visser1
Employee
Jun 22, 2017 1:09 PM UTC

Are using the uberjar?

Here are the tech-requirements: Technical Requirements . 1.7 is not supported

Translate
Level 2
Jun 22, 2017 1:05 PM UTC

Hi,

We are in the process of migrating from 5.6.1 to 6.3 I am seeing similar issue with the AEM 6.3. I am getting error -

com.day.cq.mailer,version=[5.6,6) -- Cannot be resolved

com.day.jcr.vault.util,version=[2.4,3) -- Cannot be resolved

Can you please help on with dependency I need to add for it ? Also, can I use JDK1.7 to compile backend bundles ? We are maintaining both the version currently until we fully migrate. So, just wanted to check if I can still use JDK1.7 to compile the code from jenkins build to deploy to 6.3.

Thanks,

Snehal

Translate
Feike_Visser1
Employee
Jun 9, 2017 7:57 PM UTC

Since 6.2 there is no need anymore for obfuscated-apis, just use apis

Translate
Ratna_Kumar
Level 10
Jun 9, 2017 6:54 PM UTC

Hi,

Yes, I too tested with the below dependency used.

Use this dependency under Parent POM file.

<dependency>

               <groupId>com.adobe.aem</groupId>

               <artifactId>uber-jar</artifactId>

               <version>6.3.0</version>

               <!-- for AEM6.1 use this version     : <version>6.1.0</version> -->

               <!-- for AEM6.1 SP1 use this version : <version>6.1.0-SP1-B0001</version> -->

               <!-- for AEM6.1 SP2 use this version : <version>6.1.0-SP2</version> -->

               <!-- for AEM6.2 use this version     : <version>6.2.0</version> -->

               <classifier>obfuscated-apis</classifier>

               <scope>provided</scope>

           </dependency>

           

           <dependency>

               <groupId>org.apache.geronimo.specs</groupId>

               <artifactId>geronimo-atinject_1.0_spec</artifactId>

               <version>1.0</version>

               <scope>provided</scope>

           </dependency>

Also, make sure you add this dependency in POM file under core:

       <dependency>

            <groupId>com.adobe.aem</groupId>

            <artifactId>uber-jar</artifactId>

            <classifier>obfuscated-apis</classifier>

        </dependency>

        <dependency>

            <groupId>org.apache.geronimo.specs</groupId>

            <artifactId>geronimo-atinject_1.0_spec</artifactId>

        </dependency>

Please find the attached screenshots.

We will release the new article on AEM 6.3 which uses WCMUsePojo Shortly!!

Thanks,

Ratna Kumar,

Translate